본문 바로가기
공부/코딩테스트

백준: 22193번 Multiply (Python3)

by 혼밥맨 2022. 7. 31.
반응형

백준: 22193번 Multiply (Python3)

Multiply 성공서브태스크다국어

 
시간 제한메모리 제한제출정답맞힌 사람정답 비율
2 초 128 MB 3036 1822 1713 65.133%

문제

Write a program that computes a product of two non-negative integers A and B. The integers are represented in decimal notation and have N and M digits, respectively.

입력

The first line contains the lengths N and M, separated by a space. A is given on the second and B on the third line. The numbers will not have leading zeros.

출력

Output the product of A and B without leading zeros.

제한

  • 1 ≤ N, M ≤ 50 000

서브태스크

번호배점제한
1 20 N, M ≤ 4
2 20 N, M ≤ 9
3 30 N, M ≤ 5 000
4 30 No additional constraints

예제 입력 1

3 4
123
4567

예제 출력 1

561741

예제 입력 2

3 1
100
0

예제 출력 2

0

답안

1
2
3
4
a, b = map(int, input().split())
= int(input())
= int(input())
print(a*b)
cs

반응형

댓글