백준: 20352번 Circus (Python3)
Circus 성공스페셜 저지다국어
2 초 | 512 MB | 776 | 643 | 567 | 86.433% |
문제
In the modern world, the spotlight has shifted entirely from live shows to televised recordings. Well, not entirely... One small troupe of indomitable entertainers still holds out and puts on regular circus performances.
The shows are extremely popular. Streaming media services nearby have caught on and, of course tried to cash in by opening their own circuses. However, they still need good acts to pull in crowds---and the natural solution has been to sneak into the big top to poach ideas and talent.
This can not go on. The ringmaster, inspired by his distant cousins from a small village in Armorica, proposes to build a circular wall around the big top to prevent unauthorised entry.
Figure C.1: Diagram of the indomitable circus, fencing, and the surrounding encampments of Flixium, Fundibulum, Maximillian, and Hulum. This image was adapted from an illustration of the Goseck circle by Kenny Arne Lang Antonsen.
To build this wall, enough fencing will be needed to cover a length equal to the perimeter of the circular tent. How many metres will you need to obtain?
입력
The input consists of:
- One line with an integer a (1≤a≤1018 ), the area of the circus tent in square metres.
출력
Output the total length of fence needed for the circus palisade wall, in metres. Your answer should have an absolute or relative error of at most 10−6 .
예제 입력 1
64
예제 출력 1
28.3592616145
예제 입력 2
1234
예제 출력 2
124.526709336
답안
1
2
3
4
|
import math
res = ( int(input()) /math.pi)**0.5 * 2 * math.pi
print(res)
|
cs |
'공부 > 코딩테스트' 카테고리의 다른 글
백준: 17863번 FYI (Python3) (0) | 2022.08.10 |
---|---|
백준: 20233번 Bicycle (Python3) (0) | 2022.08.10 |
백준: 20353번 Atrium (Python3) (0) | 2022.08.10 |
백준: 20499번 Darius님 한타 안 함?(Python3) (0) | 2022.08.10 |
백준: 20673번 Covid-19 (Python3) (0) | 2022.08.10 |
댓글