백준: 17863번 FYI (Python3)
FYI 성공다국어
1 초 | 512 MB | 1628 | 1308 | 1225 | 80.275% |
문제
In the United States of America, telephone numbers within an area code consist of 7 digits: the prefix number is the first 3 digits and the line number is the last 4 digits. Traditionally, the 555 prefix number has been used to provide directory information and assistance as in the following examples:
- 555-1212
- 555-9876
- 555-5000
- 555-7777
Telephone company switching hardware would detect the 555 prefix and route the call to a directory information operator. Now-a-days, telephone switching is done digitally and somewhere along the line a computer decides where to route calls.
For this problem, write a program that determines if a supplied 7-digit telephone number should be routed to the directory information operator, that is, the prefix number is 555.
입력
The input consists of a single line containing a 7-digit positive integer N, (1000000 <= N <= 9999999).
출력
The single output line consists of the word YES if the number should be routed to the directory information operator or NO if the number should not be routed to the directory information operator.
예제 입력 1
5551212
예제 출력 1
YES
예제 입력 2
5519876
예제 출력 2
NO
예제 입력 3
5055555
예제 출력 3
NO
예제 입력 4
5550000
예제 출력 4
YES
답안
1
|
print("YES" if input()[:3]=="555" else "NO")
|
cs |
'공부 > 코딩테스트' 카테고리의 다른 글
백준: 17362번 수학은 체육과목 입니다 2 (Python3) (0) | 2022.08.10 |
---|---|
백준: 17388번 와글와글 숭고한 (Python3) (0) | 2022.08.10 |
백준: 20233번 Bicycle (Python3) (0) | 2022.08.10 |
백준: 20352번 Circus (Python3) (0) | 2022.08.10 |
백준: 20353번 Atrium (Python3) (0) | 2022.08.10 |
댓글