백준: 20232번 Archivist (Python3)
Archivist 성공다국어
2 초 | 512 MB | 796 | 662 | 617 | 83.491% |
문제
The team of problemsetters of Northwestern Russia Regional Contest welcomes you! Our regional contest was founded in 1995 under the name "Collegiate Programming Championship of St Petersburg". Here is the list of the contest winners:
- 1995: ITMO
- 1996: SPbSU
- 1997: SPbSU
- 1998: ITMO
- 1999: ITMO
- 2000: SPbSU
- 2001: ITMO
- 2002: ITMO
- 2003: ITMO
- 2004: ITMO
- 2005: ITMO
- 2006: PetrSU, ITMO
- 2007: SPbSU
- 2008: SPbSU
- 2009: ITMO
- 2010: ITMO
- 2011: ITMO
- 2012: ITMO
- 2013: SPbSU
- 2014: ITMO
- 2015: ITMO
- 2016: ITMO
- 2017: ITMO
- 2018: SPbSU
- 2019: ITMO
Help the contest archivist to remember the results of each contest and write a program that will read the year and print contest winners of that year in exactly the same format as above.
입력
The only line of input contains a single integer y (1995≤y≤2019 ), denoting the year. You don't need to process year numbers less than 1995 or greater than 2019 , or incorrect year formats. It is guaranteed that you will be given a number between 1995 and 2019 , inclusive.
출력
Print the winner of the contest in year y exactly in the same format as in the list above.
예제 입력 1
2006
예제 출력 1
PetrSU, ITMO
예제 입력 2
2019
예제 출력 2
ITMO
예제 입력 3
2018
예제 출력 3
SPbSU
예제 입력 4
2003
예제 출력 4
ITMO
답안
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
|
dict = {1995: "ITMO",
1996: "SPbSU",
1997: "SPbSU",
1998: "ITMO",
1999: "ITMO",
2000: "SPbSU",
2001: "ITMO",
2002: "ITMO",
2003: "ITMO",
2004: "ITMO",
2005: "ITMO",
2006: "PetrSU, ITMO",
2007: "SPbSU",
2008: "SPbSU",
2009: "ITMO",
2010: "ITMO",
2011: "ITMO",
2012: "ITMO",
2013: "SPbSU",
2014: "ITMO",
2015: "ITMO",
2016: "ITMO",
2017: "ITMO",
2018: "SPbSU",
2019: "ITMO"}
yr = int(input())
print(dict[yr])
|
cs |
'공부 > 코딩테스트' 카테고리의 다른 글
백준: 19944번 뉴비의 기준은 뭘까? (Python3) (0) | 2022.08.07 |
---|---|
백준: 20215번 Cutting Corners (Python3) (0) | 2022.08.07 |
백준: 14489번 치킨 두 마리 (...) (Python3) (0) | 2022.08.06 |
백준: 14581번 팬들에게 둘러싸인 홍준 (Python3) (0) | 2022.08.06 |
백준: 14623번 감정이입 (Python3) (0) | 2022.08.06 |
댓글