백준: 16600번 Contemporary Art (Python3)
Contemporary Art 성공스페셜 저지다국어
1 초 | 512 MB | 1084 | 913 | 881 | 85.867% |
문제
At the Van Abbemuseum of modern and contemporary art in Eindhoven, we always look to present our muses in the most interesting way possible. Sometimes we have our work cut out for us.
Today we are exploring whether we can modify one of our perfectly-square picture frames (such as the one shown in Figure C.1) to include an electrical filament. The purpose of this filament is so that the image can set itself alight at some opportune and hilarious moment—for example, in the middle of a sale by auction.
You will be responsible for buying the filament to run around the entire perimeter of the artwork. How many centimetres will you need to obtain?
Figure C.1: A test subject for the frame.
입력
The input consists of:
- One line with an integer a (1 ≤ a ≤ 1018), the area of the image in square centimetres.
출력
Output the total length of filament needed for the frame, in centimetres. Your answer should have an absolute or relative error of at most 10−6.
예제 입력 1
64
예제 출력 1
32.0
예제 입력 2
1234
예제 출력 2
140.51334456
답안
1
|
print(int(input()) ** (1/2) * 4)
|
cs |
'공부 > 코딩테스트' 카테고리의 다른 글
백준: 16204번 카드 뽑기 (Python3) (0) | 2022.08.11 |
---|---|
백준: 16486번 운동장 한 바퀴 (Python3) (0) | 2022.08.11 |
백준: 16693번 Pizza Deal (Python3) (0) | 2022.08.10 |
백준: 16727번 ICPC (Python3) (0) | 2022.08.10 |
백준: 14489번 치킨 두 마리 (Python3) (0) | 2022.08.10 |
댓글