본문 바로가기
공부/코딩테스트

백준: 15439번 Vera and Outfits (Python3)

by 혼밥맨 2022. 8. 6.
반응형

백준: 15439번 Vera and Outfits (Python3)

Vera and Outfits 성공다국어

 
시간 제한메모리 제한제출정답맞힌 사람정답 비율
2 초 256 MB 3847 3426 3286 89.245%

문제

Vera owns N tops and N pants. The i-th top and i-th pants have colour i, for 1 ≤ i ≤ N, where all N colours are different from each other.

An outfit consists of one top and one pants. Vera likes outfits where the top and pants are not the same colour.

How many different outfits does she like?

입력

The input will be in the format:

N

Constraints:

  • 1 ≤ N ≤ 2017
  • N is integer

출력

Output one line with the number of different outfits Vera likes.

예제 입력 1

1

예제 출력 1 

0

예제 입력 2 

2

예제 출력 2 

2

예제 입력 3 

5

예제 출력 3 

20

답안

1
2
= int(input())
print(N*N-N)
cs

 

반응형

댓글